// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^dev_[0-9]+(?:.[0-9]+)+$").unwrap();
let string = "dev_1.0
dev_1.1
dev_1.2
dev_1.2.3
dev_1.2.3.4
dev1.2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}