package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^dev_[0-9]+(?:.[0-9]+)+$`)
var str = `dev_1.0
dev_1.1
dev_1.2
dev_1.2.3
dev_1.2.3.4
dev1.2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}