$re = '/^dev_[0-9]+(?:.[0-9]+)+$/m';
$str = 'dev_1.0
dev_1.1
dev_1.2
dev_1.2.3
dev_1.2.3.4
dev1.2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);