#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([a-zA-Z])[@31!]+(?=[a-zA-Z])"
Local $sString = "@@He11o Wor1d!" & @CRLF & _
"!!T3ach !m3" & @CRLF & _
"@13!" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)