import Foundation
let pattern = #"([a-zA-Z])[@31!]+(?=[a-zA-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@@He11o Wor1d!
!!T3ach !m3
@13!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)