$re = '/([a-zA-Z])[@31!]+(?=[a-zA-Z])/';
$str = '@@He11o Wor1d!
!!T3ach !m3
@13!
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;