re = /([a-zA-Z])[@31!]+(?=[a-zA-Z])/
str = '@@He11o Wor1d!
!!T3ach !m3
@13!
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result