use strict;
my $str = '@@He11o Wor1d!
!!T3ach !m3
@13!
';
my $regex = qr/([a-zA-Z])[@31!]+(?=[a-zA-Z])/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";