const regex = new RegExp('([a-zA-Z])[@31!]+(?=[a-zA-Z])', 'g')
const str = `@@He11o Wor1d!
!!T3ach !m3
@13!
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);