# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!\A)|\[(?=[^][]*]))[^]"]*\K"([^]"]*)"|"[^"]*"(*SKIP)(*F)/$1/gm;t' <<< "abc \"[\" def \"ghi\" ijk \"]\" lmn [\"opq\", \"rst\"] uvw or abc [\"def\", \"g]hi\"] jkl"