$re = '/(?:\G(?!\A)|\[(?=[^][]*]))[^]"]*\K"([^]"]*)"|"[^"]*"(*SKIP)(*F)/m';
$str = 'abc "[" def "ghi" ijk "]" lmn ["opq", "rst"] uvw or abc ["def", "g]hi"] jkl';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;