use strict;
my $str = 'abc "[" def "ghi" ijk "]" lmn ["opq", "rst"] uvw or abc ["def", "g]hi"] jkl';
my $regex = qr/(?:\G(?!\A)|\[(?=[^][]*]))[^]"]*\K"([^]"]*)"|"[^"]*"(*SKIP)(*F)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";