import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A)|\\[(?=[^][]*]))[^]\"]*\\K\"([^]\"]*)\"|\"[^\"]*\"(*SKIP)(*F)";
final String string = "abc \"[\" def \"ghi\" ijk \"]\" lmn [\"opq\", \"rst\"] uvw or abc [\"def\", \"g]hi\"] jkl";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}