const regex = /(?:\G(?!\A)|\[(?=[^][]*]))[^]"]*\K"([^]"]*)"|"[^"]*"(*SKIP)(*F)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)|\\[(?=[^][]*]))[^]"]*\\K"([^]"]*)"|"[^"]*"(*SKIP)(*F)', 'gm')
const str = `abc "[" def "ghi" ijk "]" lmn ["opq", "rst"] uvw or abc ["def", "g]hi"] jkl`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);