#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m),[\n\s\t]*(?=[}\]])"
Local $sString = "{" & @CRLF & _
" "e": "a"," & @CRLF & _
" "b": "a"," & @CRLF & _
"}" & @CRLF & _
"{"e": "a","b": "a",}" & @CRLF & _
"[" & @CRLF & _
" "e"," & @CRLF & _
" "b"," & @CRLF & _
"]" & @CRLF & _
"["e","b",]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)