import Foundation
let pattern = #",[\n\s\t]*(?=[}\]])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"e": "a",
"b": "a",
}
{"e": "a","b": "a",}
[
"e",
"b",
]
["e","b",]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)