import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",[\\n\\s\\t]*(?=[\\}\\]])";
final String string = "{\n"
+ " \"e\": \"a\",\n"
+ " \"b\": \"a\",\n"
+ "}\n"
+ "{\"e\": \"a\",\"b\": \"a\",}\n"
+ "[\n"
+ " \"e\",\n"
+ " \"b\",\n"
+ "]\n"
+ "[\"e\",\"b\",]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}