use strict;
my $str = '{
"e": "a",
"b": "a",
}
{"e": "a","b": "a",}
[
"e",
"b",
]
["e","b",]';
my $regex = qr/,[\n\s\t]*(?=[}\]])/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";