$re = '/,[\n\s\t]*(?=[}\]])/m';
$str = '{
"e": "a",
"b": "a",
}
{"e": "a","b": "a",}
[
"e",
"b",
]
["e","b",]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;