import re
regex = re.compile(r",[\n\s\t]*(?=[}\]])", flags=re.MULTILINE)
test_str = ("{\n"
" \"e\": \"a\",\n"
" \"b\": \"a\",\n"
"}\n"
"{\"e\": \"a\",\"b\": \"a\",}\n"
"[\n"
" \"e\",\n"
" \"b\",\n"
"]\n"
"[\"e\",\"b\",]")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)