re = /,[\n\s\t]*(?=[}\]])/m
str = '{
"e": "a",
"b": "a",
}
{"e": "a","b": "a",}
[
"e",
"b",
]
["e","b",]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result