using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-?(?:[1-9][2-9]\d|[2-9]\d\d|[1-9]\d{3,}))$";
string input = @"-1000
-200
-150
-1
0
1
12u
119
120
121
200
315
450
1000
1300
2300
6544
32165465465321312";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}