$re = '/^(-?(?:[1-9][2-9]\d|[2-9]\d\d|[1-9]\d{3,}))$/m';
$str = '-1000
-200
-150
-1
0
1
12u
119
120
121
200
315
450
1000
1300
2300
6544
32165465465321312';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);