import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(-?(?:[1-9][2-9]\\d|[2-9]\\d\\d|[1-9]\\d{3,}))$";
final String string = "-1000\n"
+ "-200\n"
+ "-150\n"
+ "-1\n"
+ "0\n"
+ "1\n"
+ "12u\n"
+ "119\n"
+ "120\n"
+ "121\n"
+ "200\n"
+ "315\n"
+ "450\n"
+ "1000\n"
+ "1300\n"
+ "2300\n"
+ "6544\n"
+ "32165465465321312";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}