package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(-?(?:[1-9][2-9]\d|[2-9]\d\d|[1-9]\d{3,}))$`)
var str = `-1000
-200
-150
-1
0
1
12u
119
120
121
200
315
450
1000
1300
2300
6544
32165465465321312`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}