package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+(-)?(\d+)?(\s)?kg:\d+\.\d{2}`)
var str = `2 kg:0.352-10 kg:0.8010-50 kg:1.0050-200 kg:10.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}