re = /\d+(-)?(\d+)?(\s)?kg:\d+\.\d{2}/m
str = '2 kg:0.352-10 kg:0.8010-50 kg:1.0050-200 kg:10.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end