use strict;
my $str = '2 kg:0.352-10 kg:0.8010-50 kg:1.0050-200 kg:10.00';
my $regex = qr/\d+(-)?(\d+)?(\s)?kg:\d+\.\d{2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}