// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+(-)?(\d+)?(\s)?kg:\d+\.\d{2}").unwrap();
let string = "2 kg:0.352-10 kg:0.8010-50 kg:1.0050-200 kg:10.00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}