const regex = /\d+(-)?(\d+)?(\s)?kg:\d+\.\d{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(-)?(\\d+)?(\\s)?kg:\\d+\\.\\d{2}', 'gm')
const str = `2 kg:0.352-10 kg:0.8010-50 kg:1.0050-200 kg:10.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}