# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*area\\/(.*?)\\/.*/$1/gm;t' <<< "abc/123/area/my-folder/state/..."