package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*area\/(.*?)\/.*`)
var str = `abc/123/area/my-folder/state/...`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}