using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*area\/(.*?)\/.*";
string substitution = @"$1";
string input = @"abc/123/area/my-folder/state/...";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}