re = /.*area\/(.*?)\/.*/m
str = 'abc/123/area/my-folder/state/...'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result