use strict;
my $str = 'abc/123/area/my-folder/state/...';
my $regex = qr/.*area\/(.*?)\/.*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";