const regex = /.*area\/(.*?)\/.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*area\\\/(.*?)\\\/.*', 'gm')
const str = `abc/123/area/my-folder/state/...`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);