$re = '/.*area\/(.*?)\/.*/m';
$str = 'abc/123/area/my-folder/state/...';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;