# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!,)\s(?=de\s\d{1,2}\sde\s[a-zç]+\sde\s\d{4})//gi;t' <<< "DECRETO Nº 76.326 DE 23 DE SETEMBRO DE 1975.
DECRETO Nº 76.326, DE 23 DE SETEMBRO DE 1975.
DECRETO-LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
LEI Nº 76.326 DE 23 DE MARÇO DE 1975.
Decreto Nº 76.326 DE 23 DE SETEMBRO DE 1975
Decreto Nº 76.326 de 23 DE Setembro de 1975.
DECRETO - LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
DECRETO- LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
DECRETO -LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975."