use strict;
my $str = 'DECRETO Nº 76.326 DE 23 DE SETEMBRO DE 1975.
DECRETO Nº 76.326, DE 23 DE SETEMBRO DE 1975.
DECRETO-LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
LEI Nº 76.326 DE 23 DE MARÇO DE 1975.
Decreto Nº 76.326 DE 23 DE SETEMBRO DE 1975
Decreto Nº 76.326 de 23 DE Setembro de 1975.
DECRETO - LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
DECRETO- LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
DECRETO -LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.';
my $regex = qr/(?<!,)\s(?=de\s\d{1,2}\sde\s[a-zç]+\sde\s\d{4})/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";