import re
regex = re.compile(r"(?<!,)\s(?=de\s\d{1,2}\sde\s[a-zç]+\sde\s\d{4})", flags=re.IGNORECASE)
test_str = ("DECRETO Nº 76.326 DE 23 DE SETEMBRO DE 1975.\n"
"DECRETO Nº 76.326, DE 23 DE SETEMBRO DE 1975.\n"
"DECRETO-LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.\n"
"LEI Nº 76.326 DE 23 DE MARÇO DE 1975.\n"
"Decreto Nº 76.326 DE 23 DE SETEMBRO DE 1975\n"
"Decreto Nº 76.326 de 23 DE Setembro de 1975.\n"
"DECRETO - LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.\n"
"DECRETO- LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.\n"
"DECRETO -LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)