using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!,)\s(?=de\s\d{1,2}\sde\s[a-zç]+\sde\s\d{4})";
string substitution = @"";
string input = @"DECRETO Nº 76.326 DE 23 DE SETEMBRO DE 1975.
DECRETO Nº 76.326, DE 23 DE SETEMBRO DE 1975.
DECRETO-LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
LEI Nº 76.326 DE 23 DE MARÇO DE 1975.
Decreto Nº 76.326 DE 23 DE SETEMBRO DE 1975
Decreto Nº 76.326 de 23 DE Setembro de 1975.
DECRETO - LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
DECRETO- LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
DECRETO -LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}