import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!,)\\s(?=de\\s\\d{1,2}\\sde\\s[a-zç]+\\sde\\s\\d{4})";
final String string = "DECRETO Nº 76.326 DE 23 DE SETEMBRO DE 1975.\n"
+ "DECRETO Nº 76.326, DE 23 DE SETEMBRO DE 1975.\n"
+ "DECRETO-LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.\n"
+ "LEI Nº 76.326 DE 23 DE MARÇO DE 1975.\n"
+ "Decreto Nº 76.326 DE 23 DE SETEMBRO DE 1975\n"
+ "Decreto Nº 76.326 de 23 DE Setembro de 1975.\n"
+ "DECRETO - LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.\n"
+ "DECRETO- LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.\n"
+ "DECRETO -LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}