import Foundation
let pattern = #"(?<!,)\s(?=de\s\d{1,2}\sde\s[a-zç]+\sde\s\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
DECRETO Nº 76.326 DE 23 DE SETEMBRO DE 1975.
DECRETO Nº 76.326, DE 23 DE SETEMBRO DE 1975.
DECRETO-LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
LEI Nº 76.326 DE 23 DE MARÇO DE 1975.
Decreto Nº 76.326 DE 23 DE SETEMBRO DE 1975
Decreto Nº 76.326 de 23 DE Setembro de 1975.
DECRETO - LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
DECRETO- LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
DECRETO -LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)