using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*[^;\s].*__ctrl1_.*\(";
string input = @" ; Obsidian__CTRL1_B(isHold, taps, state)
Obsidian__CTRL1_N(isHold, taps, state)
; Opus__CTRL1_Z(isHold, taps, state)
; Opus__CTRL1_X(isHold, taps, state)
; Opus__CTRL1_C(isHold, taps, state)";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}