import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*[^;\\s].*__ctrl1_.*\\(";
final String string = " ; Obsidian__CTRL1_B(isHold, taps, state)\n"
+ " Obsidian__CTRL1_N(isHold, taps, state)\n"
+ " ; Opus__CTRL1_Z(isHold, taps, state)\n"
+ " ; Opus__CTRL1_X(isHold, taps, state)\n"
+ " ; Opus__CTRL1_C(isHold, taps, state)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}