use strict;
my $str = ' ; Obsidian__CTRL1_B(isHold, taps, state)
Obsidian__CTRL1_N(isHold, taps, state)
; Opus__CTRL1_Z(isHold, taps, state)
; Opus__CTRL1_X(isHold, taps, state)
; Opus__CTRL1_C(isHold, taps, state)';
my $regex = qr/^\s*[^;\s].*__ctrl1_.*\(/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}