package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^\s*[^;\s].*__ctrl1_.*\(`)
var str = ` ; Obsidian__CTRL1_B(isHold, taps, state)
Obsidian__CTRL1_N(isHold, taps, state)
; Opus__CTRL1_Z(isHold, taps, state)
; Opus__CTRL1_X(isHold, taps, state)
; Opus__CTRL1_C(isHold, taps, state)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}