import re
regex = re.compile(r"^\s*[^;\s].*__ctrl1_.*\(", flags=re.IGNORECASE | re.MULTILINE)
test_str = (" ; Obsidian__CTRL1_B(isHold, taps, state)\n"
" Obsidian__CTRL1_N(isHold, taps, state)\n"
" ; Opus__CTRL1_Z(isHold, taps, state)\n"
" ; Opus__CTRL1_X(isHold, taps, state)\n"
" ; Opus__CTRL1_C(isHold, taps, state)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")