import Foundation
let pattern = #"^\s*[^;\s].*__ctrl1_.*\("#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
; Obsidian__CTRL1_B(isHold, taps, state)
Obsidian__CTRL1_N(isHold, taps, state)
; Opus__CTRL1_Z(isHold, taps, state)
; Opus__CTRL1_X(isHold, taps, state)
; Opus__CTRL1_C(isHold, taps, state)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)