re = /^\s*[^;\s].*__ctrl1_.*\(/im
str = ' ; Obsidian__CTRL1_B(isHold, taps, state)
Obsidian__CTRL1_N(isHold, taps, state)
; Opus__CTRL1_Z(isHold, taps, state)
; Opus__CTRL1_X(isHold, taps, state)
; Opus__CTRL1_C(isHold, taps, state)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end